add trc6500 os version debian_7.8.5
authorLaurent Mazet <laurent.mazet@thalesgroup.com>
Wed, 16 Sep 2015 18:17:51 +0000 (20:17 +0200)
committerLaurent Mazet <laurent.mazet@thalesgroup.com>
Wed, 16 Sep 2015 18:17:51 +0000 (20:17 +0200)
.gitignore
Makefile

index 210664f942ba91bcd06ae7bf1a0f6540f0aae933..577e17f1e407c2febd4e76d746ae6ce210de8e6f 100644 (file)
@@ -19,3 +19,4 @@ simple-cdd/dists/
 simple-cdd/images/
 
 trc6500-master-file/deb
+master/etc/trc6500_os_version
index 907021cc9cbb81fd1d7fa4b4406e5eedc8eda333..87c5d90cff832f0dae9b45649629d91ab7eec9f7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@ SHELL=/bin/bash
 
 MASTERFILE = trc6500-master-file
 
-VERSION = $(shell awk '/^$(MASTERFILE)/ {gsub(/[()]/, ""); print $$2; exit}' $(MASTERFILE)/debian/debian-changelog)
+VERSION = $(shell awk '/^$(MASTERFILE)/ {gsub(/[()]/, ""); print $$2; exit}' $(MASTERFILE)/changelog)
 
 ISOVER = $(shell echo $(VERSION) | sed 's/-.*$$//')
 
@@ -20,6 +20,7 @@ $(TARGET_ISO): $(ISO)
        mv $< $@
 
 $(ISO): $(TARGET_DEB)
+       echo $(ISOVER) > master/etc/trc6500_os_version
        cd simple-cdd && build-simple-cdd --dist wheezy --conf ./simple-cdd.conf
 
 masterfile: $(TARGET_DEB)