update to Debian 12 (2)
authorLaurent Mazet <mazet@softndesign.org>
Fri, 22 Mar 2024 22:20:58 +0000 (23:20 +0100)
committerMazet Laurent <mazet@debian-12.softndesign.org>
Fri, 22 Mar 2024 22:22:24 +0000 (23:22 +0100)
Makefile
master/etc/default/webconfig
simple-cdd/local_packages/webconfig_1.17.0-1_all.deb
simple-cdd/profiles/trc6500.packages
simple-cdd/profiles/trc6500.preseed
simple-cdd/simple-cdd.conf

index 21ea5a59858adb9e711db5b3830a6ce2477a045d..c9dbc382c0b43849f82b535d9f386e95ed9772a1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@ TARGET_ISO = debian-trc6500-$(ISOVER).iso
 
 TARGET_DEB = $(MASTERFILE)_$(VERSION)_all.deb
 
-all: iso masterfile
+all: fix_bookworm iso masterfile
 
 iso: $(TARGET_ISO) 
 
@@ -28,6 +28,14 @@ $(TARGET_DEB):
        echo $(ISOVER) > master/etc/trc6500_os_version
        make -C $(MASTERFILE)
 
+fix_bookworm: simple-cdd/tmp/mirror/dists/bookworm/main/dep11/Components-amd64.yml.gz
+       for key in A7236886F3CCCAAD148A27F80E98404D386FA1D9 4D64FEC119C2029067D6E791F8D2585B8783D481 4CB50190207B4758A3F73A796ED0E7B82643E131 ED541312A33F1128F10B1C6C54404762BBB6E853 B0CAB9266E8C3929798B3EEEBDE6D2B9216EC7A8; do gpg --keyserver hkps://keyserver.ubuntu.com --recv-keys $$key; done
+
+simple-cdd/tmp/mirror/dists/bookworm/main/dep11/Components-amd64.yml.gz:
+       wget ftp://ftp.fr.debian.org/debian/dists/bookworm/main/dep11/`basename $@`
+       mkdir -p `dirname $@`
+       mv `basename $@` $@
+
 clean:
        rm -f $(TARGET_DEB) $(TARGET_ISO)
 
index 195207f1c2ba97d254e306a683382abd86ad4636..32669e6d3fce9b96e310b7f341844396889732e8 100644 (file)
@@ -1,13 +1,21 @@
 # Weconfig configure options
 
-# Should webconfig be enabled?
-#ENABLED=1
+# ALIASES: filename containing form declaration
+#ALIASES="-a /etc/webconfig/alias.csv"
+ALIASES=
 
-# ALIAS: filename containing form declaration
-#ALIAS=/etc/webconfig/alias.csv
+# ALIASRC: directory containing form declaration
+ALIASRC="-r /etc/webconfig/alias.d"
+
+# CERT: filename containing ssl certificat
+# CERT="-c /etc/webconfig/cert.pem"
+CERT=
+
+# CA: filename containing ssl certificat authority
+# CA="-k /etc/ssl/certs/ca.pem"
+CA=
 
 # PORT: server port
-PORT=8080
+PORT="-p 8080"
 
-# RESOURCE: directory containing alias files
-#RESOURCE=/etc/webconfig/alias.d
+ARGS=$ALIASES $ALIASRC $CERT $CA $PORT
index 54de3bb37e6429a6a38150c048c9eb44a494b615..c33ab1ff922ef8fa0c6d74390724b04cebe0ed28 100644 (file)
Binary files a/simple-cdd/local_packages/webconfig_1.17.0-1_all.deb and b/simple-cdd/local_packages/webconfig_1.17.0-1_all.deb differ
index a5e608cf1170b7ae691568b060b77f3a0a3b9ba7..d697c75f89250813d59894f7007c623f005126fa 100644 (file)
@@ -285,3 +285,4 @@ xz-utils
 yasm
 zip
 zlib1g
+zstd
index c64f3a4c3e28904d9382b356e28f5264e3a40971..b3a5c56f96f4b706f458ea1d352051c6271320c2 100644 (file)
@@ -90,14 +90,18 @@ d-i partman/mount_style select  traditional
 
 
 # GRUB configuration
-grub grub-pc/install_devices multiselect /dev/sda
+d-i grub-installer/bootdev string default
+d-i grub-installer/only_debian boolean true
 # unlike what the internet would tell you, sending this command to d-i doesn't work
+grub grub-pc/install_devices multiselect /dev/sda
 
 # iptables configuration
-
 iptables-persistent iptables-persistent/autosave_v6 boolean false
 iptables-persistent iptables-persistent/autosave_v4 boolean false
 
+# Scan for additionnal device
+d-i apt-setup/cdrom/set-first boolean false
+
 # APT configuration
 d-i apt-setup/use_mirror boolean false
 popularity-contest popularity-contest/participate boolean false
index 733613b192e8bb542c326a79a79118dd45482e1f..18ed8c7dc57b5be234df023ba0b8563e9e6d5b6d 100644 (file)
@@ -15,6 +15,7 @@ do_mirror="true"
 debian_mirror="ftp://ftp.fr.debian.org/debian/"
 profiles_udeb_dist="bookworm"
 mirror_component="main non-free-firmware"
+export NONFREE=1
 #mirror_tools="wget"
 # default for mirror_tools is "wget reprepro". However, if we use reprepro, build-simple-cdd doesn't read the local_packages option, because it assumes reprepro has already built those into the mirror. But we're not building the mirror here, so we never actually get them. If we disable reprepro, it will actually look into local_packages.
 # Note that all this was because we were using the previously-built mirror in ./tmp instead of being connected to a repository like we'd normally do. If you don't do that just delete those things.