update to Debian 12 (2)
[debian6500.git] / Makefile
index 21ea5a59858adb9e711db5b3830a6ce2477a045d..c9dbc382c0b43849f82b535d9f386e95ed9772a1 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -12,7 +12,7 @@ TARGET_ISO = debian-trc6500-$(ISOVER).iso
 
 TARGET_DEB = $(MASTERFILE)_$(VERSION)_all.deb
 
-all: iso masterfile
+all: fix_bookworm iso masterfile
 
 iso: $(TARGET_ISO) 
 
@@ -28,6 +28,14 @@ $(TARGET_DEB):
        echo $(ISOVER) > master/etc/trc6500_os_version
        make -C $(MASTERFILE)
 
+fix_bookworm: simple-cdd/tmp/mirror/dists/bookworm/main/dep11/Components-amd64.yml.gz
+       for key in A7236886F3CCCAAD148A27F80E98404D386FA1D9 4D64FEC119C2029067D6E791F8D2585B8783D481 4CB50190207B4758A3F73A796ED0E7B82643E131 ED541312A33F1128F10B1C6C54404762BBB6E853 B0CAB9266E8C3929798B3EEEBDE6D2B9216EC7A8; do gpg --keyserver hkps://keyserver.ubuntu.com --recv-keys $$key; done
+
+simple-cdd/tmp/mirror/dists/bookworm/main/dep11/Components-amd64.yml.gz:
+       wget ftp://ftp.fr.debian.org/debian/dists/bookworm/main/dep11/`basename $@`
+       mkdir -p `dirname $@`
+       mv `basename $@` $@
+
 clean:
        rm -f $(TARGET_DEB) $(TARGET_ISO)