split apt sources list and withdraw "reseau_integration" from iso debian_7.5_20141215
authorLaurent Mazet <laurent.mazet@thalesgroup.com>
Mon, 15 Dec 2014 16:30:43 +0000 (17:30 +0100)
committerLaurent Mazet <laurent.mazet@thalesgroup.com>
Mon, 15 Dec 2014 16:30:43 +0000 (17:30 +0100)
master/etc/apt/sources.list
master/etc/apt/sources.list.d/reseau_integration.list [new file with mode: 0644]
master/etc/apt/sources.list.d/trc6500.list [new file with mode: 0644]
master/opt/cluster/Makefile
master/root/bin/deploiement_conf_reseau_integration.sh

index e55e6e85dd1cb70965bc1bc6513c809ceb5af403..899d187bbc6f8c5d57ed29a8e4742cbda04fcb04 100644 (file)
@@ -1,12 +1,9 @@
-#
+# Debian GNU/Linux 7.5.0
 
 #deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-3 20140426-13:37]/ wheezy contrib main
 #deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-2 20140426-13:37]/ wheezy contrib main
 #deb cdrom:[Debian GNU/Linux 7.5.0 _Wheezy_ - Official amd64 DVD Binary-1 20140426-13:37]/ wheezy contrib main
 
-deb [arch=amd64,all] http://192.168.0.53/debian-amd64 wheezy contrib main non-free
-deb [arch=amd64,all] http://192.168.0.53/cots softndesign main debug
-
 #deb http://security.debian.org/ wheezy/updates main contrib non-free
 #deb-src http://security.debian.org/ wheezy/updates main contrib non-free
 
@@ -17,5 +14,3 @@ deb [arch=amd64,all] http://192.168.0.53/cots softndesign main debug
 #
 # deb http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
 # deb-src http://ftp.debian.org/debian/ wheezy-updates main contrib non-free
-
-deb file:/opt/trc6500/debian-rep/ binary/
diff --git a/master/etc/apt/sources.list.d/reseau_integration.list b/master/etc/apt/sources.list.d/reseau_integration.list
new file mode 100644 (file)
index 0000000..d8fae89
--- /dev/null
@@ -0,0 +1,2 @@
+deb [arch=amd64,all] http://192.168.0.53/debian-amd64 wheezy contrib main non-free
+deb [arch=amd64,all] http://192.168.0.53/cots softndesign main debug
diff --git a/master/etc/apt/sources.list.d/trc6500.list b/master/etc/apt/sources.list.d/trc6500.list
new file mode 100644 (file)
index 0000000..2fff2e7
--- /dev/null
@@ -0,0 +1 @@
+deb file:/opt/trc6500/debian-rep/ binary/
index ccfa1c9f6a2f5869900c2224349025a0af1c19ff..782df6f81d947187caf3d955262b748b0553b8ac 100644 (file)
@@ -24,6 +24,7 @@ clean:
        -rm /opt/tftp/*.tgz
        aptitude remove $(shell apt-mark showmanual trc6500\*|egrep -v webconfig\|rproxy) ace tao myccm
        aptitude clean
+       mv -f /etc/apt/sources.list.d/reseau_integration.list /etc/apt/sources.list.d/reseau_integration.list~
        cp -f /etc/dhcp/dhcpd.conf.blank /etc/dhcp/dhcpd.conf
        chown webconfig: /etc/dhcp/dhcpd.conf*
        echo "Etc/Zulu" > /etc/timezone
index 3ed6ac121d1c376d33629fe66c657433ba63939b..8ab7d740184b3263543cf53cc57e1c705a294710 100755 (executable)
@@ -8,9 +8,10 @@
 # 2 : Sous reseau pour Clovis
 
 # globals vars
+APTSOURCES=/etc/apt/sources.list.d/reseau_integration.list
 SWITCH=0
 PROGNAME=$(basename $0)
-VER=1.0
+VER=1.1
 
 # help function
 function usage () {
@@ -46,7 +47,6 @@ route add 192.168.$SUB.160 gw 192.168.$SUB.231
 route add 192.168.$SUB.231 gw 192.168.$SUB.160
 route add 192.168.0.53 gw 192.168.$SUB.160
 
-
 if [ $SWITCH -eq 1 ]; then
     # Recuperation du chemin pour executer le script du switch depuis un chemin quelconque
     mydir=$(dirname $0)
@@ -55,3 +55,5 @@ if [ $SWITCH -eq 1 ]; then
     $mydir/conf_swm_integration.tcl $SUB
 fi
 
+# Ajout des depots debian
+[ -f $APTSOURCES~ ] && mv -f $APTSOURCES~ $APTSOURCES