update changelog
[debian6500.git] / master / opt / script / change_configuration
index ef715b75cf6567f85c39d44ae9929cd4a5cb891c..0b74a411d40b3b416c5f1bf312dc2d9b18f9a540 100755 (executable)
@@ -82,6 +82,15 @@ if [ "$MODE_BW" ]; then
     title "updating /etc/hosts"
     check rm -f /etc/hosts 
     check ln -s /etc/hosts.$MODE_BW /etc/hosts
+    check rm -f /etc/network/interfaces
+    case "$MODE_BW" in
+    30MHzMDF.lite)
+        check ln -s /etc/network/interfaces.lite /etc/network/interfaces
+    ;;
+    *)
+        check ln -s /etc/network/interfaces.default /etc/network/interfaces
+    ;;
+    esac
     TARBALLS+=" root"
     for ip in 0A851{A,C}; do check ln -T -f -s default /opt/tftp/pxelinux.cfg/$ip; done
     case "$MODE_BW" in
@@ -166,6 +175,6 @@ fi
 # last check
 [ "$action" ] || { echo "no mode specified"; exit 1; }
 
-[ "$TARBALLS" ] && make -f /opt/cluster/Makefile $TARBALLS
+[ ! "$TARBALLS" ] || make -f /opt/cluster/Makefile $TARBALLS
 
 # vim:set tabstop=4 expandtab shiftwidth=4: