force constant cpu frequencies (2)
[debian6500.git] / Makefile
index 907021cc9cbb81fd1d7fa4b4406e5eedc8eda333..87c5d90cff832f0dae9b45649629d91ab7eec9f7 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@ SHELL=/bin/bash
 
 MASTERFILE = trc6500-master-file
 
-VERSION = $(shell awk '/^$(MASTERFILE)/ {gsub(/[()]/, ""); print $$2; exit}' $(MASTERFILE)/debian/debian-changelog)
+VERSION = $(shell awk '/^$(MASTERFILE)/ {gsub(/[()]/, ""); print $$2; exit}' $(MASTERFILE)/changelog)
 
 ISOVER = $(shell echo $(VERSION) | sed 's/-.*$$//')
 
@@ -20,6 +20,7 @@ $(TARGET_ISO): $(ISO)
        mv $< $@
 
 $(ISO): $(TARGET_DEB)
+       echo $(ISOVER) > master/etc/trc6500_os_version
        cd simple-cdd && build-simple-cdd --dist wheezy --conf ./simple-cdd.conf
 
 masterfile: $(TARGET_DEB)