correct service
[debian6500.git] / Makefile
index 2c2a28ac3c0ced5afc272f4649fb485c957a8ad1..60d27476381a86d34dc044e408779e8a8d5e1d34 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -2,7 +2,7 @@ SHELL=/bin/bash
 
 MASTERFILE = trc6500-master-file
 
-VERSION = $(shell awk '/^$(MASTERFILE)/ {gsub(/[()]/, ""); print $$2; exit}' $(MASTERFILE)/debian/debian-changelog)
+VERSION = $(shell awk '/^$(MASTERFILE)/ {gsub(/[()]/, ""); print $$2; exit}' $(MASTERFILE)/changelog)
 
 ISOVER = $(shell echo $(VERSION) | sed 's/-.*$$//')
 
@@ -25,7 +25,12 @@ $(ISO): $(TARGET_DEB)
 masterfile: $(TARGET_DEB)
 
 $(TARGET_DEB):
+       echo $(ISOVER) > master/etc/trc6500_os_version
        make -C $(MASTERFILE)
 
 clean:
        rm -f $(TARGET_DEB) $(TARGET_ISO)
+
+version:
+       echo $(VERSION) $(ISOVER)
+.PHONY: $(TARGET_DEB)